summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-02-05 19:56:25 +0100
committerMattes D <github@xoft.cz>2014-02-05 19:56:25 +0100
commit4e4d92ccce17fe37f966869b11ffb3a378613d35 (patch)
tree70d7cfbf2517a385b0ea6beac1bdc98000f4da58 /CMakeLists.txt
parentMerge pull request #646 from worktycho/warningfixes (diff)
parentSimplified shutdown (diff)
downloadcuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar.gz
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar.bz2
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar.lz
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar.xz
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.tar.zst
cuberite-4e4d92ccce17fe37f966869b11ffb3a378613d35.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1fee887e7..57b200a2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,10 @@ endif()
# The Expat library is linked in statically, make the source files aware of that:
add_definitions(-DXML_STATIC)
+# Self Test Mode enables extra checks at startup
+if(${SELF_TEST})
+ add_definitions(-DSELF_TEST)
+endif()
# Declare the flags used for profiling builds:
if (MSVC)